solving electrical gremlines *now with added hope...(well..)

Rust problems and repairs, leaky sunroof... Battery, starter, lights, fuses, airco, heating unit, stereo... | Tuning: custom spoilers & bodykits, fiberglass parts...
NO parts requests here, please use our V3M BUY & SELL corner
User avatar
Edcase 300
Posts: 201
Joined: 15 Oct 2008 10:29 am
Location: Basingstoke, Hampshire, UK.

Electrical gremlins-soon to be...(with added lack of initiat

Post by Edcase 300 » 28 May 2010 08:15 pm

That makes sense. The starter and such works-with the Ht leads giving good spark.Im thinking that its likely to be either Red wire from the Fuel Pump to the Fusebox or The Red one the other side of the Fusebox.The aux fusebox needs sorting-which im going to do too.What i don know its that the LE Jet relay is working as i got dad to test it and pretty much most relays in the car.

I just want her to work again :cry: :lol:
Last edited by Edcase 300 on 06 Jul 2010 03:52 pm, edited 1 time in total.
F reg Volvo 360 GLT 118k miles (My first car) RIP
G reg Volvo 340 1.7 122k miles (Started my Interest in Volvo 300s) RIP
Currently Driving a Citroen AX 1.0 'Eco-Box Stopgap' :-i
One Day... Volvo 360 Turbo ;-)

User avatar
Edcase 300
Posts: 201
Joined: 15 Oct 2008 10:29 am
Location: Basingstoke, Hampshire, UK.

Re: Anyone good with electronics/solving electrical Gremlins

Post by Edcase 300 » 31 May 2010 06:00 pm

Right...I got my ass in gear and undertook some investigative work which has brought about some good news and some Sh!T news.... :roll:

Im scratching my head...after cleaning contacts etc,new (and correct) fuses,and testing the most obvious bits with a homemade test light (zener diode + led combo)... grrr my fuel pump works :) BUT..

my fuel pump is pumping fuel even the igniton isnt on (just battery connected) i.e im not cranking the starter,no key in ignition!

im ever so slighlty irritated & i know im a numpty but... does anyone know what might be the cause of this constant pumpage? :?

Again any feedback muchly appreciated.
F reg Volvo 360 GLT 118k miles (My first car) RIP
G reg Volvo 340 1.7 122k miles (Started my Interest in Volvo 300s) RIP
Currently Driving a Citroen AX 1.0 'Eco-Box Stopgap' :-i
One Day... Volvo 360 Turbo ;-)

User avatar
Edcase 300
Posts: 201
Joined: 15 Oct 2008 10:29 am
Location: Basingstoke, Hampshire, UK.

Re: Anyone good with electronics/solving electrical Gremlins

Post by Edcase 300 » 31 May 2010 07:10 pm

I reconnected everything as it was before the vehicle was running.Only difference is that the fuses before were wrong rating.Now has right ratings and contacts are clean.My problem is that the fuel pump runs even just by connecting the battery & without the key in the ignition.

Help much appreciated-pretty annoyed with Vulva & the numpty who owned her before me tbh :roll:
F reg Volvo 360 GLT 118k miles (My first car) RIP
G reg Volvo 340 1.7 122k miles (Started my Interest in Volvo 300s) RIP
Currently Driving a Citroen AX 1.0 'Eco-Box Stopgap' :-i
One Day... Volvo 360 Turbo ;-)

User avatar
volvodspec
Posts: 1921
Joined: 06 Dec 2008 09:35 pm
Location: Netherlands.
Contact:

Re: Anyone good with electronics/solving electrical Gremlins

Post by volvodspec » 31 May 2010 07:41 pm

did you disconnect the wires of the fuelpump relay?

what does the fuel pump do if you prime it by key?

User avatar
Edcase 300
Posts: 201
Joined: 15 Oct 2008 10:29 am
Location: Basingstoke, Hampshire, UK.

Re: Anyone good with electronics/solving electrical Gremlins

Post by Edcase 300 » 31 May 2010 09:06 pm

hey thaqnks for the reply :)
i didnt try those.
im going to try priming it by key (in theory should work now)...

i think i know what you mean about the fuel pump relay wires -maybe there was some kind of short in the wires? i will test the wires... :P
(the relay its self seems to work-i got my dad to test a whole load of relays from the car (all which seem to work after testing).

cool so i'll try that & let you know if i find something.thanks for the help-im really new to all this sm4
F reg Volvo 360 GLT 118k miles (My first car) RIP
G reg Volvo 340 1.7 122k miles (Started my Interest in Volvo 300s) RIP
Currently Driving a Citroen AX 1.0 'Eco-Box Stopgap' :-i
One Day... Volvo 360 Turbo ;-)

User avatar
Edcase 300
Posts: 201
Joined: 15 Oct 2008 10:29 am
Location: Basingstoke, Hampshire, UK.

Re: Anyone good with electronics/solving electrical Gremlins

Post by Edcase 300 » 31 May 2010 10:42 pm

Hi again :lol: I jiggled the fuel pump relay and primed the ignition with the fuel pump in... the fuel pump is working.(I got dad to observe the fuel pump as i pu the ignition on..i quickly got under the car and heard the pump buzzing... then turned the ignition off... lolz

BUT it decided to keep on pumping without the key in (again) ..so i had to quickly disconnect the fuel pump wires :shock: I disconnected the vehicle battery & put it on chatge to spare it but Im going to test the wires that go to the fuel pump with my homemade testlight when i next get a chance.. it seems very odd :?
F reg Volvo 360 GLT 118k miles (My first car) RIP
G reg Volvo 340 1.7 122k miles (Started my Interest in Volvo 300s) RIP
Currently Driving a Citroen AX 1.0 'Eco-Box Stopgap' :-i
One Day... Volvo 360 Turbo ;-)

User avatar
Edcase 300
Posts: 201
Joined: 15 Oct 2008 10:29 am
Location: Basingstoke, Hampshire, UK.

Re: Anyone good with electronics/gremlins-now with pics..RE-

Post by Edcase 300 » 08 Jun 2010 07:44 pm

Rebump on old thread... :roll: :P


Image

The blooming hose (above) was not only loose but also filthy.. does anyone know what it does & ist effect if not coonnected properly?

Below pic is of a Broken battery terminal :shock: lolz

Image

and below...(fuses replaced with correct ones (according to v3m wiring pdf) & contacts cleaned... (i wonder if its correctly connencted?

Image

The test lamp (zener diode & led) home made thingy (dad made me it ofcourse) :lol:

Image

Blooming car...any thoughts appreciated :?
F reg Volvo 360 GLT 118k miles (My first car) RIP
G reg Volvo 340 1.7 122k miles (Started my Interest in Volvo 300s) RIP
Currently Driving a Citroen AX 1.0 'Eco-Box Stopgap' :-i
One Day... Volvo 360 Turbo ;-)

Ride_on
Posts: 2233
Joined: 26 May 2009 05:34 pm
Location: Belfast, N. Ireland

Re: Anyone good with electronics/solving electrical Gremlins

Post by Ride_on » 09 Jun 2010 12:31 am

AFAIK the fuel pump is only driven from the control relay, pull out the fuse and the relay. Then put them in one at a time. That might tell you something. If the voltage is coming from the relay and it only goes when it is in then the relay is faulty or incorrectly wired.

How do you know the relay is working properly? It would be a complex test to check it properly.
1980 345 DL_______1987 360 GLE (project car restored to GLT spec and B230FT'd)
1984 360 GLT______1987 360 GLT
1983 360 GLS______1989 360 GLE
1985 340 GL_______1986 340 1.4
1985 360 GLS______1995 940 SE 2.3 Turbo Estate (daily)
1987 340 GL 1.7

User avatar
Edcase 300
Posts: 201
Joined: 15 Oct 2008 10:29 am
Location: Basingstoke, Hampshire, UK.

Re: Anyone good with electronics/solving electrical Gremlins

Post by Edcase 300 » 09 Jun 2010 10:45 pm

Im going to have a try at that ... see what happens etc.

My dad tested my relays for me (im not smart with electrics unfortunatley tbh)-im not sure what he did exactly...

Problem is the vehicle's electrics were never great when i got it 4 yrs ago.. just seems odd that the car stopped working then after cleaning out contacts, putting correct fuses on fuel pump and so forth it now has the weird pump problem.

Im thinking it might be the wiring to the fuel pump relay (imean the loom under the relay) or maybe something to do with the ignition switch? mmm :roll:


URL=http://s976.photobucket.com/albums/ae24 ... usebox.jpg]Image[/URL]

These fuses weree on the fuel pump fusebox before :shock: Completley wrong rating according to V3M Wiring PDF.. and im assuming they were buggered as when i put in the fresh + corerct fuses in the pump worked from the ignition. Crazy though aas if fuse goes then circuit is no longer complete right? :lol:
F reg Volvo 360 GLT 118k miles (My first car) RIP
G reg Volvo 340 1.7 122k miles (Started my Interest in Volvo 300s) RIP
Currently Driving a Citroen AX 1.0 'Eco-Box Stopgap' :-i
One Day... Volvo 360 Turbo ;-)

User avatar
volvodspec
Posts: 1921
Joined: 06 Dec 2008 09:35 pm
Location: Netherlands.
Contact:

Re: Anyone good with electronics/solving electrical Gremlins

Post by volvodspec » 09 Jun 2010 10:53 pm

yeah and i still wonder what happens with the fuel pump if you start it/ run the engine

it could be that the pump is then off wich would indicate that the relay is wrong wired and rewiring it solves the problem

User avatar
Edcase 300
Posts: 201
Joined: 15 Oct 2008 10:29 am
Location: Basingstoke, Hampshire, UK.

Re: Anyone good with electronics/solving electrical Gremlins

Post by Edcase 300 » 09 Jun 2010 11:15 pm

:oops: i miss read your last posted post man.
i havent tried starting the engine with the change of fuse... so i will give it a go during the wkend... might well be that it doesnt start (wouldnt surprise me tbh). :?
F reg Volvo 360 GLT 118k miles (My first car) RIP
G reg Volvo 340 1.7 122k miles (Started my Interest in Volvo 300s) RIP
Currently Driving a Citroen AX 1.0 'Eco-Box Stopgap' :-i
One Day... Volvo 360 Turbo ;-)

User avatar
Edcase 300
Posts: 201
Joined: 15 Oct 2008 10:29 am
Location: Basingstoke, Hampshire, UK.

Re: Anyone good with electronics/solving electrical Gremlins

Post by Edcase 300 » 06 Jul 2010 03:49 pm

(Thread RE-BUMP) :oops:

Rightyo- my oldman wont let me start her and i dare not argue with him :roll:

Im really not sure what the hell my dad did when 'testing' the relays but it seems odd that the wiring would be wrong...

Would i be correct in stating that the relay completes the circuit from the battery side + ignition side Red wire , to the relay (circuit switch) to the other Red wire in the loom which then goes to the fusebo, (through fuse) to red wire to fuel pump?

Only thing i can think of after numerous mini study sessions at the wiring diagrams is that the relaay is screwed?

The relay controls the whole Le-jet system... thing is if the relay switch circuit was stuck closed then that would explain why the pump is on (testlight in situ in place of relay permanently on... when fuse if taken out circuit is incomplete and its not on.

(do tell me if im correct or incorrect-it sounds mega obvious but im a noob with this type of system)

If what im thinking is correct then im guessing i need a new LE Jet relay? If so-does aanyone know where/if i can still get this part? How much a new one costs?

Things are getting done know at home- as my parents will need the other 2 cars to get to thier work and i need Vulva to get me to work - sm4

As always thanks for the help guys and patience btw im still very nieve to all this :P (lolz and yes i am slow with technical stuff-im the arty type (excuse) lolz :lol:
F reg Volvo 360 GLT 118k miles (My first car) RIP
G reg Volvo 340 1.7 122k miles (Started my Interest in Volvo 300s) RIP
Currently Driving a Citroen AX 1.0 'Eco-Box Stopgap' :-i
One Day... Volvo 360 Turbo ;-)

Ride_on
Posts: 2233
Joined: 26 May 2009 05:34 pm
Location: Belfast, N. Ireland

Re: solving electrical gremlines *now with added hope...(wel

Post by Ride_on » 07 Jul 2010 10:36 pm

Yes could be the relay. It is supposed to switch on the pump when there are pulses from the flywheel sensor, so that if you crash and the engine stops the fuel pump doesn't continue.

If you are sure it could not be wired incorrectly then take out the relay and smack it on the ground a few times, that might free it but its a long shot and it might happen again. I should have one spare if you need it, PM me with address and offer. As a bodge you could wire in a manual switch but it would be not crash safe then.

Also don't worry too much about the pump continually going when testing, the fuel is a full return system, the fuel will just flow back to the tank if the injectors are not switching on. There is a mechanical pressure regulator that keep the pressure in the fuel rail constant(ish), surplus fuel just goes back to the tank.
1980 345 DL_______1987 360 GLE (project car restored to GLT spec and B230FT'd)
1984 360 GLT______1987 360 GLT
1983 360 GLS______1989 360 GLE
1985 340 GL_______1986 340 1.4
1985 360 GLS______1995 940 SE 2.3 Turbo Estate (daily)
1987 340 GL 1.7

User avatar
Edcase 300
Posts: 201
Joined: 15 Oct 2008 10:29 am
Location: Basingstoke, Hampshire, UK.

Re: solving electrical gremlines *now with added hope...(wel

Post by Edcase 300 » 09 Jul 2010 08:02 pm

Hey thanks for the offer sm4 I will PM you regarding the Relay-er :lol:
F reg Volvo 360 GLT 118k miles (My first car) RIP
G reg Volvo 340 1.7 122k miles (Started my Interest in Volvo 300s) RIP
Currently Driving a Citroen AX 1.0 'Eco-Box Stopgap' :-i
One Day... Volvo 360 Turbo ;-)

Post Reply